« MBS FileMaker Plug-in… | Home | MBS FileMaker Plugin … »

Java with MBS Plugin


As you may know we support loading Java in both Xojo via MBS Java Plugin and FileMaker via Java functions to call java code. Due to a change in Java 9, the existing plugin doesn't find the jvm.dll on Windows automatically. You can of course just pass the right path to the functions to load it and bypass the automatic.

For Mac and 32-bit applications, you can install Java for OS X 2015-001 and if you run our examples, they will simply work and return java.version with "1.6.0_65".

For Mac and 64-bit application, you can of course use Java 1.6. But we prefer to use version 9. You simply install version 9 and now you see the plugin still loads version 6 unless you fix JavaVM framework manually. But a better fix is to pass in a custom path of the jni library. e.g. in Xojo:

JavaVMMBS.SetLibraryPath "/Library/Java/JavaVirtualMachines/jdk-9.0.4.jdk/Contents/Home/lib/jli/libjli.dylib"

But for next plugin version we added code to find the latest Java version and load it's library automatically. So you don't need to pass in the path.

For Windows in a 64-bit app you get "9.0.4", if you get the Java 9 library loaded and query java.version system property. To have this work better, we improved the loading code there, too.

So for the upcoming version 18.1 (Xojo) and 8.1 (FileMaker) of our plugins, you should be able to use Java 6, 7, 8 and 9 easily without hassle. If you want a specific version, you can always pass in the file path.

If you like to try it soon, you can always contact us for a test copy of the plugin.
28 01 18 - 14:29
No comments

  
Remember personal info?

Emoticons / Textile


Notify:
Hide email:

Small print: All html tags except <b> and <i> will be removed from your comment. You can make links by just typing the url or mail-address.